2

I've not access to the production environment so I can't see the ULS log.

I've got several 2010 workflows that worked pretty well yesterday. But today they suddenly stopped working. When I try to manually start a workflow I get "Sorry something went wrong" and "file not found".

So I thought it was some errors in my custom workflow. So I just added a new custom list and added a simple 2010 workflow, that add a extra element in the list. -> published. When I look in the library workflow, I can see the workflow. But then I try to start the workflow it fails "file not found". When I try to modify the view to see the workflow column it does not appear!

I've tried many different workflows without any luck! Then I tried to add a OOTB workflow and it runs!

I'm in a SP2013 environment, and I've tried:

  • Restarting the workflow feature
  • Tried to add a simple workflow in another site collection, fails
  • 1
    Check the ULS logs for complete error trace, try to restart workflow timer jobs, restart the SharePoint Timer services.....is it publishing site? – Waqas Sarwar MVP Dec 17 '14 at 17:08
  • Yes, it's a publishing site. Witch SharePoint timer services should I restart? (Central admin?) – Plexus81 Dec 17 '14 at 17:11
  • 2
    You have to make sure "Workflow" timer jobs run successfully. If you dont have CA/ server access then it will be tough to identify issue... – Waqas Sarwar MVP Dec 17 '14 at 17:22
0

System administrator run

Disable-SPFeature -Identity WorkflowServiceStore -Url http://superawesome.info -Force

Then you have to reenable the feature again. And a IIS reset

That worked :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.