3

I want to ask how to uninstall and remove the solution package from SharePoint Server 2010 thoroughly?

I have a problem when I deploy a solution in SharePoint Server 2010. This solution had deployed in one web application, in fact it needs to deploy to all web applications. So I redeployed to all web applications. Meanwhile my colleague did other things in the same server, and the service administratif was stopped. So my seconde deployment was not succeeded.
Then I tried the third deployment, but the Deployment Status was Error, it had a error message on 2 farms: "A feature with ID AAAA has already been installed in this farm. Use the force attribute to explicitly re-install the feature." So I did:

  1. Uninstall the Solution (via PowerShell, and it reminded the solution has not been deployed yet, so I removed this solution directly)
  2. Remove the solution
  3. Re-add the solution
  4. Redeploy the solution (choose all web applications)

But the same error message appears.

Then I did Uninstall the feature:

stsadm -o uninstallfeature -id "ID GUID" –force   

Opreation completed successfully. Then I redeploy the solution. But Deployment Status was always Error, and the same error message appears however ID GUID is changed BBBB. So I redid Uninstall the feature and redeploy. Then the same error message appears with ID GUID AAAA. It looks like "uninstall the feature" does not work. I don't know how could I do.

Could you give me some good ideas, please? Thank you all.

0

Couple of things:

  1. Make Sure Admin Services is running on all server in farm.
  2. Can you see the Solution from Central Admin and try to remove it from their?
  3. try to install with force feature. Is it Gacdeployment.

Worst case Scenario( not recommended in Production), Manually delete the DLL from the Gac and also feature from 14/15hive. I did only once in my life.

Also try this tool SharePoint Manager 2010, their is 2010 version on the page.

Check this one good resource http://blogs.msdn.com/b/kaevans/archive/2011/02/02/sharepoint-don-t-forget-to-uninstall-the-feature.aspx

0

I found the feature ID in folder C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\FEATURES

There are 7 features for this solution.

I use stsadm to uninstall all features, then I redeploy the solution:

stsadm -o uninstallfeature -id "ID GUID" –force 

It works

0

Setting Force attribute while installing a solution using PowerShell will help resolving this issue. That way, you don't need to manually uninstall features one by one. Example:

install-spsolution -identity SOMEWSPNAME.wsp -force -gacdeployment -webapplication http://aissp2013

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.