1

I have configured SharePoint Foundation 2013 to work on my local env (SQL machine + server with SP installed and VS to deploy/debug). In order to test apps I have created certificate for high trust apps and run essential services (UPS is not running) – everything looks fine, I can debug simple provider-hosted apps. Lately I decided to add Remote Event Receivers to my app, but unfortunately they didn’t work. In case of simple RER, like ‘list item added’ they have never been fired, in case of app events (like App Installed) it was even worse – I could not run app. App Installation process exits with following error:

@"Error 1
CorrelationId: 1647e119-e814-46a0-a762-aaee3ab841c7
ErrorDetail: The remote event receiver callout failed.
ErrorType: Transient
ErrorTypeName: Intermittent
ExceptionMessage: System.ArgumentException: Specified value has invalid Control characters.

I have tried to find similar issue, but with no success. I also tried to find sth in ULS logs, but couldn’t find anything meaningful. Instead of that I receive strange error –

“Microsoft.SharePoint.SPException: The Azure Access Control is unavailable”.

Why do I get this error while I am not using any of Azure services on my local env? I would be really grateful for help.

P.S. OAuth over http is turned on.

1

After long hours of research I found a solution/workaround for my problem and I decided that sharing it may help somebody in the future.

First of all I have modified AppManifest file and replace RemoteWebApplication tag:

<AppPrincipal>
    <Internal/>
</AppPrincipal>

Next I have disabled SSL in Web project. After those operation it was necessary to set up Multiple startup projects in solution properties, because web project did not start automatically (IMPORTANT: web project has to be first on a list). Now remote event receivers should trigger normally. In case of problem with running ClientContext.ExecuteQuery() (Exception of Access denied type or 403 Foridden)

I advice to try to modify ClientId in web.config file - default SharePoint application identifier should solve the issue (00000003-0000-0ff1-ce00-000000000000)

Hope that it will save others time that I had to spent on a research:)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.