0

For some reason, SharePoint saw fit that we would not be able to use a lookup in a lookup, so I have been doing the workaround where you use a workflow to copy the contents of the first lookup into a dummy text field and then you do the second lookup on that.

Unfortunately this is falling apart when I try to pull in additional columns with the workaround because it seems like I can't use those in workflows.

To make this more concrete, I have the following lists:

Companies:    [Title], 
Divisions:    [Title, Company (Lookup on Companies:Title), CompanyString], 
Employees:    [Name, Email, ..., 
               Division (Lookup on Divisions:Title), 
               Company (Pulled over Divisions:CompanyString with Divisions:Title), 
               DivisionString, CompanyString],
Appointments: [Meeting (Lookup, not related to question), 
               Employee (Lookup on Employees:Name), 
               Company (Pulled over Employees:CompanyString with Employees:Name)]

Since I can't do a lookup on a lookup, all of the fields ending in "String" are hidden fields set via workflow on item edit or creation. However, since Company was pulled over with Division, it won't let me use it in a workflow, therefore I can't set the CompanyString, therefore I can't make the Company Lookup in the Appointments table.

Does anyone know how to use "pulled over" info in a workflow? Or if there has been a miraculous fix that allows lookups of lookups? I would prefer not to move into cascading drop downs because I know that the only solutions for this are third party JavaScript libraries and I'd rather something out of the box.

0

There are a lot of things you want to happen in this Workflow. are you using timers? If not try waiting.

Reason is that some of your actions might get lost as you do not have control over what happens first. By waiting for every field and logging you can be sure where you encounter the "problem" and then troubleshoot around it.

updating lookups

  • It isn't really a timing issue, and also, it's multiple workflows. The problem is that the workflow won't allow me to access the Company field in Employees at all. The table above is what I was trying to do, not what I actually have. I got stuck because when I went to Appointments and did the lookup on Employees:Name, I tried to pull over Employees:Company as well, but since that is a lookup, I can't. So instead, I tried to use a workflow to copy Employees:Company into Employees:CompanyString, but Employees:Company is not available in workflows unfortunately. That is the crux of the problem. – user3380049 Dec 16 '14 at 13:45
  • then try saving values in local varables and reusing – Cherubel Dec 16 '14 at 14:09
  • That's exactly the problem, the value I want isn't available in workflows. I can't use it or store it in a variable because it doesn't appear in the options list. – user3380049 Dec 16 '14 at 20:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.