I have several search scopes set up in Search Administration, one of which is the default All Content scope which includes everything but items with a contentclass of SPSPeople. On my advanced search page in the Search Center, all of these scopes are available for searching, and All Content is selected as the default scope. If a user selects another scope in addition to the All Content scope (which is admittedly redundant), the following appears in the results view:

Your search cannot be completed because of a service error. Try your search again or contact your administrator for more information.

This only happens with the All Content scope. There are other scopes which are also supersets of smaller scopes, and these can be selected together with their sub-scopes without problems. Also, the All Content scope works fine when used by itself. There are no relevant messages I can find in the ULS logs.

I know that this is a silly search to do and don't expect it to be done intentionally. The problem comes when a user forgets to uncheck "All content" when checking another scope -- I'd rather they still get results (maybe it will even be apparent that they selected their scope improperly), than get this error message.

One workaround would be to remove the All Content scope from the Advanced Search display group in the site collection settings. But that requires me to select a different (narrower) default scope, and I need the Advanced Search page to default to searching all content.

Can anyone help me out? Thanks!

2 Answers 2


I had never tried to search against multiple scopes before, but I just reproduced this issue on my production farm where I had the advanced search web parts configured. The searches work fine individually, but not if the custom scope is searched in addition to the "All Sites" scope. My assumption is that it is because the scopes point to the same records in the index, i.e. it is a redundant search.

I think you will either need to define the narrower scopes or do the search on All Content (All Sites).

  • I thought it might have something to do with it being a redundant search too, but other similarly-redundant searches work fine: I have one scope that's just the union of several other scopes, and you can successfully search that "parent" scope in combination with any of its "child" scopes. Jan 25, 2010 at 18:03
  • Also, could you expand on what you mean by "define the narrower scopes"? I already have the narrower scopes defined. Jan 25, 2010 at 18:16
  • Lets say that A is all sites and .1, .2, and .3 are subsets of the content. You could select both .1 and .2 instead of A and .1. Jan 25, 2010 at 22:36

Here's the workaround I've decided to use for now: I deleted the All Content rule from the All Content scope, and manually added a new rule to the scope to include content from each of my four Content Sources. This new scope appears to circumvent the problem, returning search results from all content even if a narrower sub-scope is also selected.

  • I guess that confirms the limitation that All Sits (All Content) cannot be used in conjunction with another scope by definition. Jan 25, 2010 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.