0

I have a List View WebPart that I need to asynchronously take a parameter from an HTML form WebPart and update the LVWP. I have some odd behavior happen when I attempt this. I have Async Load, Update, & manual refresh set to true for the LVWP. I have connected the HTML Form web part to the LVWP.

If I synchronously submit the HTML Form, the filter works as expected. I can also then submit the form with an Async Manual Refresh, and it works as expected. The issue I am facing is that on the initial load of the page an Async Manual Refresh of the list is NOT filtering results.

Async Function

__doPostBack(ctl00$SPWebPartManager1$g_<{WebPartID}>$ctl02","cancel")

Again, this function works as expected after 1 synchronous submission but not without one. Anyone seen this before?

Update

This is exactly what I am trying to do but with no luck...

Filter SharePoint list with Partial Postback to page

  • have you tried using a different approach? I've triggered the manual refresh before using the image inside the a $("#ManualRefresh").click() before with much success. – Eric Alexander Dec 10 '14 at 21:26
  • If I click the ManualRefresh img without first synchronously submitting, the manual refresh doesn't work.I need to be able to filter the LVWP initially without synchronously submitting. – ExceptionLimeCat Dec 10 '14 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.