0

I'm creating a custom display form for a document library in SharePoint 2013 using SharePoint Designer. The problem is that the text in the multiple lines of text column (Notes in the screenshots below) does not retain their formatting, specifically carriage returns. The first image below is the default DispForm.aspx file. The second image is my custom DispForm. As you can see in the first image, the carriage returns I put in the field work correctly but those carriage returns are not in the custom form.

How do I make the carriage returns work in my custom form?

I've already applied the disable-output-escaping option.

<xsl:value-of select="@Notes0" disable-output-escaping="yes"/>

Default DisForm.aspx form

Custom DisForm.aspx

0

XSLT attribute disable-output-escaping will help you here.

In your form you have to do something like this.

<xsl:value-of select="@Notes" disable-output-escaping="yes" />

Hope this helps.

  • Unfortunately, I've already added the disable-output-escaping XSLT option with no change. – Michael Harley Dec 9 '14 at 22:35
  • Hmmm....It would be easier to provide some solution if you can update the relevant code block in the question. – Amit Tyagi Dec 9 '14 at 22:43
  • Update the code block how? – Michael Harley Dec 12 '14 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.