1

I keep getting correlation-id errors on all Lists when creating SharePoint online sites using CSOM. I am using example http://www.vrdmn.com/2014/03/create-site-collections-with-csom-in.html. Furthermore the site is being ceated correctly (except for all lists, including siteassets)

I changed all of the references in my c# console application pointing to version 15 or 16 dlls (64-bits). No difference.

Microsoft.Online.SharePoint.Client.Tenant (version 16.0.2617.1200)

Located:

C:\Program Files\SharePoint Client Components\16.0\Assemblies\Microsoft.Online.SharePoint.Client.Tenant.dll

Microsoft.SharePoint.Client
Microsoft.SharePoint.Client.Publishing
Microsoft.SharePoint.Client.Runtime

Anyone any idea what is causing this issue? It drives me mad! Cannot figure it out.

Thanks!

enter image description here

  • Site collections take a few minutes to spin up. Could it be possible that you're hitting the site before everything is provisioned? – Derek Gusoff Dec 9 '14 at 15:35
0

Finally figured out the solution to this issue. Appeared to be the wrong TimeZoneId property value was set. This was causing the correlation-id errors. Needed to be value 4 for (UTC+01:00) Amsterdam, Berlijn, Bern, Rome, Stockholm, Wenen

To figure out the correct TimeZoneId needed execute code below on any existing site.

ClientContext context = new ClientContext("site url"); 
var culture = context.Web.RegionalSettings; 
context.Load(culture); 
var tz = culture.TimeZone; 
context.Load(tz); 
context.ExecuteQuery(); 
context.Dispose();

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.