0

How can I remove this search box from the sidebar on my site? It appears everywhere and for some reason doesn't stay in the bounds of the sidebar. We don't really have a use for it...

enter image description here

Thanks in advance for any help provided!

UPDATE:

So far, in response to the answer below, I have tried adding the following to the site master page just before the closing head tag:

#SearchBox { display: none; }

<style type="text/css">#SearchBox { display: none; }</style>

I tried to wrap these changes into a content editor web part to see if that will help the CSS to activate. Doesn't appear to work.

I now have the default master page again.

2

Yes you can remove it from Master Page.

Using CSS

  1. Edit Master page
  2. Add following just before </head>

    #SearchBox { display: none; }
    
  • Doesn't seem to work. Do I need other stuff like <style/> tags? Sorry, I don't actually know any CSS. – user3380049 Dec 8 '14 at 14:48
  • Yes. <style type="text/css">#SearchBox { display: none; }</style> – Amal Hashim Dec 8 '14 at 14:49
  • Hmm...I used exactly that and it didn't work. Does it maybe have some kind of a refresh time on it? – user3380049 Dec 8 '14 at 14:52
  • No. Using browser developer tool check the ID of the search box is SearchBox. msdn.microsoft.com/en-us/library/ie/… – Amal Hashim Dec 8 '14 at 14:58
  • Yeah, that's the right ID. I tried going a little higher ("searchInputBox") but that didn't help either... – user3380049 Dec 8 '14 at 15:11
0

If you are using custom master page and if you have publishing feature enabled. You need to check the option Reset master page inhering all sites and sub sites" under master page.

Also try switching the master page to default and then to custom and try the scenario.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.