1

Good morning,

I am trying to include some custom properties to our Search Results. These are the steps I have followed so far:

  1. Create User Profile Service Property and sync to AD. The property is populated for different users.
  2. Run full crawl
  3. Create managed property on the Schema, and map this to the crawled property
  4. Created a new version of the Item_Person.html template and changed its title.
  5. Upload to the Display Templates gallery, and created a new Result Type with this as its template
  6. Added the new property to the mso:ManagedPropertyMapping tag
  7. Went to Search Result Types, and selected "Update" on the Property Sync alert
  8. On the new template, the new property appears on the object ctx.CurrentItem, but its value is null.

Am I missing something? Tried running full crawl and incremental crawl. Even tried removing the index first.

  • On 3. You need to map crawled property like "People:CustomProperty" And in Content Source you need sps3://Site On 6. you need to call that property blogs.technet.com/b/tothesharepoint/archive/2013/09/11/… Under How to modify an item display template to show values from custom managed properties - option 1 – Marko Tica Dec 3 '14 at 21:24
  • Did you resolve this? – Matthew McDermott Dec 21 '14 at 15:48
  • I did. Not sure if my answer will be helpful as it seemed to be specific to my case, but I will post an answer anyway as it might help – Gonzalo Dec 23 '14 at 12:57
0

I'm not sure if this was indeed the reason why it started to work, but on my case I had created the properties through the site's search schema. I deleted these properties, and created these through Central Admin instead. Then it worked.

Hope it helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.