0

I have a Content Query Web Part (CQWP) which is pulling in links from a specific Content Type that I have on all subsites. All I need is the link and all of the data to be displayed in 3 columns. I tried using the out of box function and although it works, it is not working correctly. The alignment for my three columns are not evenly spaced out and look strange. Is there any way to fix this?? Does anyone have any ideas of how to fix this issue?? If an XSL solution could you please help give me some code to work with?

Thanks in advance!

enter image description here

  • This (msdn.microsoft.com/en-us/library/bb447557%28v=office.14%29.aspx) link may help. – Amit Tyagi Dec 1 '14 at 19:55
  • Thank you for the example from microsoft however it does not address the issue of multiple columns in the article. I know there are articles online but if an XSL solution like the link mentioned it would be nice to have some code to go with it – Kam Dec 1 '14 at 21:59
0

Check if this helps. You need to do changes in ItemStyle.xsl

<div class="description">
<td><xsl:value-of select="@ProjectProperty.Title" /> </td>
<td><xsl:value-of select="@Status" /></td>
<td><xsl:value-of select="@Priority" /></td>
<td><xsl:value-of select='ddwrt:FormatDate(string(@DueDate),1044,1)' /></td>
<td><xsl:value-of select='format-number(@PercentComplete,"#%")' /> </td>
</div>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.