0

I am having a lot of problem publishing my SharePoint App, the 2013 version should be an easier version to process but I can't seem to make it work.

I'm using currently Visual Studio 2013 and this are the steps I took

Still I can't seem to properly publish my site, I kept having errors like this: enter image description here

Now I'm not sure which part of my step is wrong because I'm trying to deploy a newly created Sharepoint Site, and the localhost is fantastically working yet once I deploy I kept having this error

Edit* This is the error that was shown:

Could not load file or assembly 'Microsoft.Owin, Version=2.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

which is weird because when I run it localhost it works just fine

  • Do what the screen says so we can view the error. Edit your web.config and add the customErrors node. That will then give us the actual error that you're having. – z.rahui Nov 27 '14 at 7:09
  • Hi I edited my post so you can see clearer to my problem – Franz Justin Buenaventura Nov 27 '14 at 14:41
0

Follow this blog article to view full error. Once you get the error details, you will be able to trace further, what's wrong with your configuration or code.

  • Actually I don't quite get the error, I mean I tried publishing another web then I change the AppManifest for the link of my site and still same error – Franz Justin Buenaventura Nov 26 '14 at 15:28
0

Make sure you set 'Copy Local' to True (do this in Visual Studio on your Web project) for assemblies that are required. This is also true for any Microsoft.SharePoint.* assemblies that you may be using.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.