0

I am having problems with my portal (which a newbie has created) in the company I recently joined to get my hands dirty with MOSS 2007; I have no prior experience in SharePoint as I am more of a .NET expert.

In the last couple of months our users are getting the following error quite often:

HTTP/1.1 404 Connection: close Date: Thu, 22 Oct 2009 04:57:41 GMT Server: Microsoft-IIS/6.0 MicrosoftSharePointTeamServices: 12.0.0.6219 X-Powered-By: ASP.NET

I went into the log files in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\LOGS and filtered on High priority. I found the entries listed below. It seems like there is a problem with Single Sign On, which I need to know how to rectify:

MSSCNTRS: Cannot get perf statistics on library SSO.
Error code is: -2147418113
Event ID : 8kh7 Access denied
There is no Web named "/hr/Policies related to FTE/Forms/AllItems.aspx".
There is no Web named "/hr/JoiningIn Documents For FTE/Forms/AllItems.aspx".
There is no Web named "/hr/Staff Declaration  Agreements for FTE/Forms/AllItems.aspx".

I've noticed that the error code "-2147418113" is usually followed by "Access denied" and then "There is no web named ... ".

How do I go about fixing this?

1

"There is no Web named" errors are not really errors and can be ignored. It seems to occur when you have the Publishing feature turned on and relative links in the Quick Launch. So, there is probably another reason for your 404 errors.

You should have more success using the IIS log to troubleshoot the 404 errors. Refer to this link for help with IIS logging:

Tom Kaminski: Troubleshooting a 404

  • fine but what about Error code is: -2147418113 and Event ID : 8kh7 Access denied ?? – user239684 May 5 '11 at 5:42
1

SharePoint performs a lot of logging (particularly 2007), and a lot of it can be safely ignored - even messages at high severity levels.

It's a mystery to many people what some of these messages are, and Microsoft rarely document them unless they really are a problem. That's how I would approach viewing the error logs. If you aren't experiencing problems on your farm, then monitor but don't be concerned unless an issue actually arises.

1

Log Entries 4, 5, 6: There is no Web named "" is related to Navigation.

If you have "Office SharePoint Server Publishing Infrastructure" feature activated at Site Collection level (http://<Site url>/_layouts/ManageFeatures.aspx?Scope=Site),

When trying to add a link to navigation at http://<web URL>/_layouts/AreaNavigationSettings.aspx, your relative link will be resolved.

if the link can't be resolved (not found), or not resolved to a list item, list, web, site...etc...(I don't know the inclusive list)... then the log will have this entry: There is no Web named "/sites/sample/List 1/Forms/My List.aspx".

In your case, link to a Form (Forms/AllItems.aspx) caused this to happen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.