1

I have a document library in my SharePoint 2013 site. (I have SharePoint Foundation.) I want to allow people to add documents and also to view documents (and save them locally to their own PC) but I DO NOT want them to be able to check out files or edit them. We are having a problem with people saving files back to the document library with their own personal information on them. I ALWAYS want the original file to stay in the document library (unless admin deletes it).

In versioning settings I have no versioning. I do not know how to do this. I just don't want any kind of a check out and/or edit option at all. How is this accomplished?

2

You can create a new permission using specific permission level. Maybe you can call it "Add and View" or something similar. In the site collection site settings, you can create a new permission level that you get to pick and choose the permissions you want the user with it to have.

  • Site Settings -> Users and Permissions -> Site Permissions
  • Manage -> Permission Levels
  • Add a Permissions Level
  • Choose the permissions you want to add
  • Create
  • Add the users to this permission level for the site/library/item, etc.

More on this.

  • So I had created a new permissions group from before and had the following Grant permissions: List Permissions: Add Items View Items Open Items View Versions Site Permissions: View Pages Open I left Owners having full control, Visitors having read control, and 'Everyone' having Read and new Generic Add Items permission level (shown above). When I have it this way, I had someone test. When they tried adding a document, it says, 'Sorry, this site has not been shared with you.' I don't understand why this would happen because they Add Items permission level should allow them to add items. – Amanda B. Nov 21 '14 at 20:23
  • Copy the Read permission level and just add the "Add Items" permission. To do this, Click the Read permission level, and at the bottom click "Copy", then add the Add Items permission and Name the permission level then click create. – Mike Nov 21 '14 at 21:52
  • They are still getting the same message. – Amanda B. Nov 21 '14 at 22:29
  • did you add that permission level to that library? It seems as though it may have been uninherited. – Mike Nov 21 '14 at 22:41
  • When I go to Library Settings, then Permissions for this document library, 'Everyone' is under the Add Items permission level that I created. – Amanda B. Nov 24 '14 at 15:02
1

I have stumbled upon the same issue and the only simple way I found out to solve it is to disable obligatory check out for library and then create custom permission level:

  1. go to library settings -> versioning -> Require documents to be checked out before they can be edited? = No

  2. Create custom permission level (e.g. by copying Contribute level) and remove permission to edit and delete items.

This problem arises from the document status. The document cannot be checked in, because users have no rights to access edit form (you get access denied because of that). (I am still wondering why Sharepoint is opening Edit form instead of NewForm in this case).

At the same time the document has no checked in version at all and therefore it is not visible to others (although it is uploaded and can be seen in library settings -> Manage files which have no checked in version).

The limitation of this solution: users will not be able to assign item metadata fields of the file.

0

Just to tag on to the other answer

Full Control - exactly what it sounds like

Design - Can create lists, documents, edit pages, etc.

Contribute - Can add, edit, and delete items

Read - read only access. Can view items and pages.

Limited - granular level permissions.

More detail here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.