I have a very weird problem. I am trying to run a very basic provider hosted application on VS2013 (Update 3). The application stops debugging every now and then. The only thing I get in Output console is -

The program '[10816] iexplore.exe' has exited with code 0 (0x0).
The program '[10536] iisexpress.exe' has exited with code 0 (0x0).

I tried to find reason for this behavior but sadly, I couldn't. This happens ONLY when I run provider hosted application. For other apps like MVC, Cloud it works flawlessly.

Anyone encountered the same issue? I would love to the solution.

  • Just to be sure: You have set Ping Enabled to False in IIS for the respective application pool(s)?
    – eirikb
    Nov 25 '14 at 7:56

There are 3 solutions to this problem.

Solution 1
1. Close down dev environments
2. Go to Documents folder and rename IISExpress.
3. Now set environment variable _CSRUN_DISABLE_WORKAROUNDS
(ref: http://gauravmantri.com/2013/02/05/workaround-for-iis-express-crashing-when-running-windows-azure-cloud-service-web-role-with-multiple-instances-in-windows-azure-sdk-1-8-compute-emulator/ ).
4. Now reboot PC, start VS, load website and run in debug. IIS automatically regenerated the IISExpress folder and the environment variable resolved conflicts.

Solution 2
Uninstall "Telerik JustMock Q3 2013 (13.3.1015.0)" if you are using it.

Solution 3
1. Open Solution Explorer in Visual Studio.
2. Right click on the web project, chose properties and then navigate to the "web" tab.
3. Change Project URL to another port number. For example, if it is http://localhost:1052 then change it to http://localhost:4356


  • I tried all the solutions but it did not solve problem :-( Nov 29 '14 at 8:08
  • Changing port numbers won't help just because everything is happening over SSL / HTTPS.. Port change doesn't work for https Nov 29 '14 at 8:09

a quick solution would be to follow Franks solution 1 but slightly different :)

1 Go to Documents folder and look for iisexpress folder

2 go into the folder and look for config file

3 rename config to config.backup

4 refresh by clicking F5 (debug) in visual studio and should be all good togo ;)


Check out this article:


Hope it helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.