1

I have added Excel access webpart to a page in SharePoint. When I click on edit webpart properties, I can't see all the properties which I should see by default. Any idea why? I can just see appearance, layout and advanced options.

We migrated from 2010 to 2013 but masterpage is still 2010. Also note that we have not installed Excel services. But the property should be visible, right? I know it doesn't make sense when you don't have Excel service installed but you know how client behaves.

Actual Webpart properties for Excel access webpart

The problem I am facing is below screenshot. All top 3 properties are hidden.

Problem I have with web part properties. all top 3 properties are hidden

  • Is this a migration? What version are you using? – Mike Nov 24 '14 at 14:20
  • Yes. Migrated from 2010 to 2013 but masterpage is still 2010. Also not that we have not installed excel services but the property should be visible right? i know it doesnt make sense when you dont have excel service installed but you know how client behaves – SharePointMan Nov 25 '14 at 7:19
  • 1
    Create an Excel Services Service Application and turn on the Excel Calc Services, and you should be good to go. Make sure that the client has Enterprise Features enabled on the farm. – Mike Nov 25 '14 at 14:04
1
+50

You need Excel services to show data. It doesn't matter that you're using the 2010 version for masterpage as it shouldn't really effect it!

You could try one thing though, by setting the 2013 site as 2010. You will still run under the same issue though! The webpart is still the same.

I have a strong feeling even though not tested is that you need to have excel services running before you can see those custom configurations. I presume if it's not active than you should have the option to set something that would break the webpart. When you save the webpart properties those custom parts will communicate with the Excel service and if it's not available than it wil fail.

Here is a quick read which I should have done but it proves that I'm correct is this statement.

Excel Services enables these commands automatically. To disable one or more of the commands, clear the check box for that command.

https://support.office.com/en-us/article/Excel-Web-Access-Web-Part-custom-properties-f08198de-c476-4e20-bea7-64248d46304e

It was hidden and should have been highlighted like above! But that is your answer, the Excel service is your issue.

You should have set up all service that you require before you migrate the contents over! Now you might get complications that even though you activate and install Excel services it still might not appear!

I would test to make sure that the above is correct by adding another excel webpart to page and see if the properties appear. Then add the excel service and check the webpart again to edit the properties. You should see the properties - check with 2010 migrated webpart if it's ok; if not check with 2013 webpart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.