4

When I go to "Manage Servers in Farm" from Central Admin, I see a red alert that says "Upgrade Required" against web front end. When I run the stsadm command

stsadm.exe -o localupgradestatus

, I get the following output:

<objects>
  <object>
    <name>SharePoint_Config</name>
    <type>Microsoft.SharePoint.Administration.SPConfigurationDatabase</type>
    <level>0</level>
    <status>Needs Upgrade</status>
  </object>
</objects>

[0] content database(s) encountered.
[0] content database(s) still need upgrade or cannot be upgraded.
[0] site collection(s) are contained in the content databases.
[0] site collection(s) still need upgrade.
[1] other objects encountered, [1] of them still need upgrade or cannot be upgraded.

I Tried psconfig command :

psconfig -cmd upgrade -inplace b2b -wait

and the result was:

SharePoint Products Configuration Wizard version 15.0.4569.1503. Copyright (C) M icrosoft Corporation 2012. All rights reserved.

The upgradebootstrap command is invalid or a failure has been encountered.
An error has occurred while validating the configuration settings.  An exception of      
type System.Data.SqlClient.SqlException was thrown. Additional exception in
formation: The EXECUTE permission was denied on the object 'proc_GetProductVersions',    
database 'SharePoint_Config', schema 'dbo'.

Can anyone tell me what I need to do?

  • Hello, did you ever get a solution for this. I'm having the same issue just with an application server running search services. – John G Jun 2 '16 at 14:56
1

I know this is an old question, but one of mine did this too. It worked on my test server, then I got this on our production server. I may have not ran the prompt as administrator, so when I tried again in as admin it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.