0

I've created a "branding" site with Sharepoint 2013. I'm not being able to configure the search engine so that it finds the content from the custom web parts. Most "static" content (institutional content) from the web site are displayed through custom web parts.

So my approach now is to try to configure the Content Search with "Web site" type, in order to have the crawl processing all pages as a regular website. But it's not working, it seems to keep crawling as a Sharepoint site, because the content from webparts are not being "searchable", even if I remove the "MicrosoftSharePointTeamServices" http header.

So, how could I configure the search in order to have the contents from web parts "searchable"?

2 Answers 2

0

There are a couple things you can try. I would start by creating a crawl rule for your web site and select the option to "Crawl SharePoint Content as HTTP Pages". You can also try crawling the site anonymously and see if your results improve. It takes a bit of trial and error to get the results the way you want.

5
  • Thank you Matthew, unfortunately I've been trying those approaches with no success. I'm also sure all pages have the whole html content being crawled (I used fiddler to monitoring that). Commented Nov 19, 2014 at 22:26
  • Hmm, is resetting the index and recrawling an option? I have seen cases where previously crawled pages don't reindex correctly after a change to crawl rules. Once you get the crawl rule working try that. Commented Nov 20, 2014 at 20:09
  • tried that, same problem, no results :( Commented Nov 21, 2014 at 3:37
  • Can you watch the crawl through Fiddler? That way you can "see what the crawler sees". ableblue.com/blog/archive/2012/01/04/… Commented Nov 27, 2014 at 13:04
  • Yes I used Fiddler and could see that the whole content was being generated on the pages. Somehow Sharepoint appear to decide to not use that content. I'm not sure if the content is being discarded, or maybe I'm missing some configuration to force that content to be part of the results. Commented Nov 27, 2014 at 17:55
0

Finally found the answer!

All webparts are rendered with class="noindex" by default, which causes crawl process to ignore it.

To solve the issue: go to "Site Settings" -> "Search and offline availability" and for "Indexing ASPX Page Content" configuration select "Always index all Web Parts on this site".

This will make sharepoint do not include "noindex" class anymore.

If there are any subsites, the configuration must be done at subsite leve as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.