1

I have tried to methods to add background image to my SharePoint site. But both of the methods loads very slow. the background loads white first then picture after a few seconds.

Methode 1: Using Script editor with CSS.

  .ms-backgroundImage {
  background-image: url('https://xxxx.sharepoint.com/xxxx/SiteAssets/hall.jpg');
  background-repeat: no-repeat;
  background-attachment: fixed;
  background-position: center;
  background-size: 100% 100%;
  }

Methode 2: Site settings -> "Change the look" and add the picture there. but it still loads really slow.

Should I host the file somewhere else or? What should I do to make it load faster

  • Is this happening for the first page load? Which version of SharePoint you are using? How big is the image size? Can you change the browser and check the behavior? – Amal Hashim Nov 17 '14 at 13:28
  • Happens all the time. In google chrome the image loads then it turns white then it loads again. I have tried .jpeg also but still loads slow. The images is 1920 x 1080 – Nikolai Skillicorn Nov 17 '14 at 13:31
  • In this case your image would normally be too large and thus takes a few seconds to load. This is causing the white screen you see first. Try changing the background image to a 100 x 100 image and see if this speeds up your page loading time (Your can put repeat on just for this exercise) – Vince2322589 Nov 17 '14 at 13:46
  • I did try to use 1440 x 900, seems like its loading faster now atleast. – Nikolai Skillicorn Nov 17 '14 at 14:14
  • By using a larger image you will find that the page might be white at first and then later have the image as it loads the image into memory. That is why you'll need to use a file with a smaller size. Connection speed can also affect how fast the image loads when going to the site. – Vince2322589 Nov 17 '14 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.