1

In the main ribbon there is a menu for the different views for a list. This menu also shows in the breadcrumb of a listview page.

But if you add a webpart to a listview page, it is no longer a listview page. The breadcrumb disappears and the ribbon is hidden until you click on a list item.

Now, I really like to add Content Editor webparts to my listviews to provide directions or keys or links or filter boxes, so I always have the problem of the missing listview breadcrumb and the missing ribbon, which means users cannot have an easy way to change views.

So how can I get a menu of available views into a Content Editor Webpart?

2
  • Please tag the SharePoint version Nov 14, 2014 at 20:16
  • Sorry, I really meant to do that in the first place.
    – bgmCoder
    Nov 14, 2014 at 20:17

1 Answer 1

0

This is the default behaviour of SharePoint. This happens when there are more than one webpart in a page. In such scenario SharePoint doesn't know which is the default webpart and which type of ribbon controls it should display (Ribbon controls vary of individual webparts)

You should use JavaScript to click the listview webpart and that will enable the ribbon

var defaultWP = document.getElementById("MSOZoneCell_WebPartWPQ2");
WpClick({target:defaultWP,srcElement:defaultWP});

Make sure you get the correct web part id. Use Developer Tool to find that.

http://www.glynblogs.com/2011/02/list-view-selector-missing-with-multiple-web-parts-in-sharepoint-2010.html

1
  • I already know it is the default behaviour of Sharepoint. I am asking how to get the menu of views of the listview. That was my question.
    – bgmCoder
    Nov 14, 2014 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.