6

In a sharepoint.com trial site, for my root site collection, I can't upload master pages (or anything else for that matter). I tried deleting the root site collection and re-creating it as a publishing site, but I keep getting the same error: Access denied.

I can access the Master Page Gallery just fine, and in the Files tab of the ribbon, choose either New Document or Upload Document. However as soon as I select something, I get "Sorry, you don't have access to this page". I have site collection admin, and am in the site owners group.

I have tried requesting permission, and granting myself full control. I also went to the library settings of the master page gallery library and tried from there. I also can't open the root site collection in SharePoint Designer, I get a 403 Forbidden response. I am able to do this on other non-root site collections, just not for the root site colleciton.

What gives?

6

**SOLVED ** The problem is related to 'Scripting Capabilities' being turned off by default for the root site collection in Office 365.

https://support.office.com/en-us/article/Turn-scripting-capabilities-on-or-off-1f2c515f-5d7e-448a-9fd7-835da935584f?ui=en-US&=amp&rs=en-US&ad=US

Although it mentions turning on scripting through the Sharepoint Admin Settings and waiting 24 hours, this did not work for me.

The Powershell script in same article did work, immediately :

 Set-SPOsite "SiteURL" -DenyAddAndCustomizePages 0
0

I was only able to solve this after filing a ticket with microsoft. Their solution was to delete my root site collection and then re-add it as a team site.

After that I was able to enable publishing features.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.