8

I set up an office 365 developer account and I;m trying to add a CEWP to the page. I can't find the CEWP anywhere. I've enabled publishing to see if that was the issue but it didn't help. Not sure what to try next.

This is what I see: enter image description here

  • You can check Site Settings -> Webparts and make sure MSContentEditor.dwp is there or not. – Amal Hashim Nov 13 '14 at 17:55
  • The web parts settings are missing entirely. – Batman Nov 13 '14 at 18:08
  • Which is your O365 plan? – Amal Hashim Nov 13 '14 at 18:09
  • From what I'm seeing "Office 365 Developer Pack" – Batman Nov 13 '14 at 18:10
  • I've enable developer feature,[Can see it] Activate Office SharePoint Server Publishing Infrastructure and Office SharePoint Server Publishing feature. Enable Custom Script. Still Content Editor Webpart is not appeared in the gallery.. Any help on this truly appreciated.. thank you ananda – ananda sanyal Jul 16 '17 at 5:44

11 Answers 11

10

The top level site collection uses the Developer Template which doesn't come with the Content Editor Web Part. I had to create a new Site Collection using the Team Site template and all the features I'm used to showed up.

  • 1
    The developer template does have the content editor. Look at the changed screenshot in my answer. I created a new site collection based on Developer template just to check if there were any changes to the template recently - it still does have the content editor and it's enabled by default. – grisha Nov 15 '14 at 15:36
  • Then I really don't know what's going on. Honestly, I feel like if I did create a new site collection with the dev template it would probably show up. But for some reason, at the main site collection www.mycompany.sharepoint.com it's not there. – Batman Nov 15 '14 at 16:52
  • >> The top level site collection .. doesn't come with.. - How weird!!... Thank You for sharing, it helps! – Gennady G Jun 19 '16 at 15:01
  • Deleting and creating a new site collection based on the developer template fixed it for me. So it looks like it doesn't have to be Team Site template. Before recreating the site collection, I tried enabling script in admin center, enabled publishing features, etc... and none of it worked. – Tom Jun 20 '17 at 6:19
5

You need to activate Publishing features for both Site Collection and Site level

  1. Site Settings > Site Collection Administration > Site Collection Features -> Office SharePoint Server Publishing Infrastructure
  2. Site Settings > Site Actions -> Manage Site Features -> Office SharePoint Server Publishing feature.
  • Thank-you. This is the only solution that worked for me and it was very straight forward. After adding #1, I was successfully able to add a Script Web Part to my site and get things running. – Doug Aug 14 '17 at 14:11
2

Enable the options 'Allow users to run custom script on personal sites' and 'Allow users to run custom script on self-service sites' in the Custom Script setting in the SharePoint Admin Console.

Settings can take up to 24 hours to become active across your site.

2

I found the answer from this site http://mstechtalk.com/missing-web-part-features-office-365/

Login to Office365 account

Open the SharePoint Admin center

Click Settings in left column

Scroll down to Custom Script section

Click selection Allow users to run custom script on personal sites

Click selection Allow users to run custom script on self-service created sites

Scroll to bottom and click Save button

According to the description of this setting, it may take up to 24 hours to take effect

To make the change effective quickly, it will require using PowerShell to connect to SharePoint online and run one cmdlet. You will need to change each line for your relevant credentials and sharepoint URLs

$adminUPN="userid@mstechtalk.com"

$orgName="mstalk"

$userCredential = Get-Credential -UserName $adminUPN -Message "Enter password"

Connect-SPOService -Url https://$orgName-admin.sharepoint.com -Credential $userCredential

Set-SPOsite https://mstalk.sharepoint.com -DenyAddAndCustomizePages 0 
1

Go to office365 admin>Sharepoint>Setting>Custom Script>enable it

  • Can you please elaborate your answer with some brief description. – Asad Refai Sep 2 '15 at 5:34
1

Instead of using existing team site, please go ahead and create new team site under new site collection.

That will work for you.

I did this and it works in seconds. https://www.youtube.com/watch?v=eMwBIpnEh1o

1

Enable the Custom Script feature via SharePoint admin center > https://DOMAIN-admin.sharepoint.com/ > Settings > https://DOMAIN-admin.sharepoint.com/_layouts/15/online/TenantSettings.aspx

Custom Script > Allow users to run custom script on self-service created sites >It takes about 24 hours for the change to take effect.

If the issue persists, follow the steps below to enable publishing feature : A. Go to Site Settings > Site Collection Administration > Site Collection Features >

https://DOMAIN.sharepoint.com/_layouts/15/ManageFeatures.aspx?Scope=Site > SharePoint Publishing Infrastructure > Activate. B. Go to Site Settings > https://DOMAIN.sharepoint.com/_layouts/15/ManageFeatures.aspx Site Actions > Manage site features > SharePoint Server Publishing > Activate.

If you do not want to wait for 24 hours, then use this powershell command :


$adminUPN="USERID@DOMAIN.onmicrosoft.com" $orgName="DOMAIN" $userCredential = Get-Credential -UserName $adminUPN -Message "Enter password" Connect-SPOService -Url https://$orgName-admin.sharepoint.com -Credential $userCredential

Set-SPOsite https://DOMAIN.sharepoint.com -DenyAddAndCustomizePages 0


please replace DOMAIN in URL with your domain, before clicking on link.

0

Do you mean this web part? This is a screenshot from my Developer Site Collection.

enter image description here

If the web part is missing in all your site collections/subsites, they may not be provisioned correctly. Try to recreate them if you have such a possibility. If it doesn't help, you may need to contact Microsoft to fix it for you. If it's a trial account, can you set up a new one?

  • I opened a service ticket with them so I'll be talking to someone today. I am were you are but I have a lot less options in the Media and content category. This is what I see: i.imgur.com/hHJbSC8.png – Batman Nov 14 '14 at 14:46
  • When you have an answer, can you share the steps that led to solution or if it was some backend stuff they did? – grisha Nov 15 '14 at 12:55
0

It's weird but for SPO fristly I had to add at least "View only" permissions to web part library or selected web part (depend on your needs ...../_catalogs/wp/Forms/AllItems.aspx) for choosen user/group. Next I had to add "Design" permission for user/group on Site level and finally I had to add at least "Contribute" permissions to Site page. For some reason most important permissions are on Site level - the rest of permissions are only for Site/Page access.

Regards Artur

-1

There's webpart named HTML Form Web Part in Forms group. It allows you put your own HTML code into the page. It's successor of CEWP.

  • That webpart has been around for a while. I dont think its the successor. – Batman Nov 14 '14 at 0:57
-1

For anyone looking for the solution to this in the future, this was what I found:

https://support.office.com/en-us/article/Turn-scripting-capabilities-on-or-off-1f2c515f-5d7e-448a-9fd7-835da935584f?ui=en-US&rs=en-US&ad=US

Short answer:

You need to enable the "Custom Script" feature from your Site Admin Center. This will take about 24 hours to kick in. The link above has a dropdown titled "Features affected when scripting is disabled" which includes the 'Content Editor' Web Part.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.