0

I'm trying to use AAM do redirect a webapplication that was used the run over HTTPS but now is just gonna run over basic HTTP. I notice that using AAM for this is not working.

I have removed the binding for SSL, and can access the site using HTTP, but some are still trying to access the site using HTTPS.

We have the IIS Redirect plugin installed but i have only managed to find how to rewrite from HTTP to HTTPS. I have found the following rule but have not managed to get it to work.

<rule name="ForceNonHttps" stopProcessing="true">
  <match url="(.*)" ignoreCase="true" negate="true" />
  <conditions>
      <add input="{SERVER_PORT}" pattern="^443$" />
  </conditions>
  <action type="Redirect" redirectType="Found" url="http://{HTTP_HOST}{REQUEST_URI}" />
</rule>

How can i make sure that the users get redirected or the URL get's rewritten to HTTP?

1
+50

The redirection configuration snippet looks fine to me, to redirect incoming HTTPS traffic using IIS Redirection you'll first have to make sure IIS is actually listening to the HTTPS traffic for your Applications old URL. I'll make an assumption regarding your setup and say your SP 2010 Farm has a Single Web Front End (WFE) and no Reverse Proxies are in the picture, your SharePoint Web Applications are hosting Path-Based sites and there aren't any other IIS Sites with SSL bindings which could possible receive traffic intended for the Web Application in question...

So unless you've manually created an IIS Site then nothing is listening to the SSL traffic [on standard port 443]. If nothing is listening then it doesn't matter how you configure redirection, it obviously can't redirect traffic it's not receiving.

At this point I feel I need to point out that manually editing IIS setting on a SharePoint Web Front End is something you really really want to avoid if at all possible! SharePoint likes exclusive use of IIS and manually editing IIS settings has a potential to cause real problems.

Continuing on regardless and assuming I've correctly guessed your architecture then to accomplish what you trying to do you'll need to manually create a new IIS site which has similar bindings as the IIS Site created by SharePoint, the difference being of course that it'll only be listening to SSL traffic on port 443. Once you have a dedicated IIS Site listening for the traffic then configure the IIS Redirection there; IIS Redirection should not have any configuration on a SharePoint IIS Site.

Once you have this working any Web Browser visiting the old HTTPS URL will be redirected as expected however Office data connections and the Office client applications in general will throw errors.

I'd like to say that unless you have a very good reason I'd recommend you keep your Default zone as it was (on HTTPS), if it's ever a possibility you'll upgrade to SP 2013 I expect you'll find yourself wanting to return to SSL.

I'd like to ask just how "AAM for this is not working"? If you haven't already come across it then reading Alternate Access Mappings (AAMs) *Explained may help you understand your current configuration a little better and help you find a way to your desired configuration.

Finally I'll just throw out a possible simple alternate configuration (which will probably have it's own share of problems). Assuming path-based site collections and a Web Application extended to a IIS site on port 80 then manually add a SSL binding to the SharePoint IIS Site and in AAM add the HTTPS URL as an Internal URL on the same zone as the HTTP URL. The initial page request will be served over SSL but the links should transition the user to HTTP.

  • Thankes James for taking your time! – Christoffer Nov 24 '14 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.