1

I have configured and enabled RBS on the CLUSTERED content database as per the following article

http://technet.microsoft.com/en-us/library/ee748631(v=office.15).aspx#enableRBS

However, I need to clarify the following as it is different from an article to another:

  1. Do I have to install the RBS.msi file on the sql server? or just the web servers in the farm?
  2. After installing and configuring everything as per the article mentioned above, SharePoint still stored the documents in the content database and not in the blob folder.

Anyone has any clue on how to troubleshoot this?

1
  • Have you managed to solve this problem? This also happened to me, SP2016 with SQL 2016. Running sp_filestream_force_garbage_collection show 0. I event tried migrate it back to content db, but the storage was still being used by filestream. Doing numerous backup & checkpont didn't delete that storage.
    – Ariwibawa
    Apr 10, 2021 at 6:57

1 Answer 1

0

To enable RBS you must ensure following steps

  1. Enable File Stream In SQL
  2. Enable Blob Store on the Content Database in Question
  3. Install RBS client library in on first server (Sharepoint Web Server) using command

    msiexec /qn /lvx* rbs_install_log.txt /i RBS_amd64.msi TRUSTSERVERCERTIFICATE=true FILEGROUP=PRIMARY DBNAME="WSS_Content" DBINSTANCE="DBInstanceName" FILESTREAMFILEGROUP=RBSFilestreamProvider FILESTREAMSTORENAME=FilestreamProvider_1
    
  4. For the remaining servers (WFE & APP) install client library using command

    msiexec /qn /lvx* rbs_install_log.txt /i RBS_amd64.msi DBNAME="WSS_Content" DBINSTANCE="DBInstanceName" ADDLOCAL=Client,Docs,Maintainer,ServerScript,FilestreamClient,FilestreamServer
    
  5. Using PowerShell enable RemoteBlobStorageSettings

Now you can validate this by uploading a document and then opening the file path.

1
  • I have done that...still does not work
    – Ohh
    Nov 12, 2014 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.