0

I'm trying to allow SharePoint 2010 to open PDFs in browser.We are using Adobe Reader X.

I follow the instructions here: How can I force SharePoint 2010 to open PDF's in the browser?

However, after I have done IISRESET, it still forcefully opens in Adobe.

I'm guessing that this is because of the new SharePoint Integration features in Adobe Reader X.

Anyone encountered this and what is the solution you have done?

Thank you!

2

I was facing the same problem. Here is a solution that finally worked for me.

Open

%ProgramFiles%\Common Files\Microsoft Shared\web server extensions\14\TEMPLATE\XML\DocIcon.xml

There you should see a line

<Mapping Key="pdf" Value="icpdf.png" OpenControl="PdfFile.OpenDocuments"/>

Change it to

<Mapping Key="pdf" Value="icpdf.png" OpenControl="SharePoint.OpenDocuments"/>

(if you don't want the SharePoint open file prompt use this

<Mapping Key="pdf" Value="icpdf.png" OpenControl=""/>)

and do IISRESET.

But to note, there are some drawbacks

  1. You have to do this step on each front-end web server (or deploy a farm feature that does the change)
  2. Your change may be overwritten in future versions

Caution

If you modify DocIcon.xml, you must make identical changes on each front-end web server so that all servers remain in sync. A good way to do this would be to distribute changes to DocIcon.xml as part of a farm-level Feature. In addition, you should be aware that changes that you make to DocIcon.xml may be overwritten when you install updates or service packs to SharePoint Foundation, or when you upgrade an installation to the next product version.

See this link: Understanding DocIcon.xml Files

| improve this answer | |
  • Thanks Dolgsthrasir! Tried it out and it worked, although there were still prompts from the browser to either "Read-Only or Edit" or "You are opening a file that can harm your computer". I read that you need to disable the SharePoint Open Document Active X control to not show the prompts. I tried it another way (using the Regedit method to disable Adobe SharePoint Integration) and it also works, but without the prompts. – Water Nov 13 '14 at 1:42
  • You can also disable the prompt if you change the line to <Mapping Key="pdf" Value="icpdf.png" OpenControl=""/> – Dolgsthrasir Nov 20 '14 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.