0

I have commented out the top link bar and am using a jQuery solution instead. This is to get options for dropdown and open in new window in Foundation 2010. While the solution works fine on home and site pages, I've noticed "all site content" and "site settings" pages are showing the default top link bar.

What's odd is other masterpage branding customizations work fine on these other pages no problem. Any suggestions?

edit: To add some more information. I have looked in Dev tools and there are no javascript errors. What's odd is I do not see my reference to to the scripts at all. Does "all site content" and "site settings" somehow have a different body? I feel like I must be misunderstanding something here. Thanks!.

  • Have you made the changes to both the site master and system master pages? All Site Content and Site Settings use the system master page. – Ransher Singh Nov 11 '14 at 21:09
  • I've only made changes in a custom masterpage I created and set as "Custom master page" in SPD. I have learned in further reading that system pages in _layouts use the system master. My users won't interact with this much so I'll probably just leave it. – Chris Nov 11 '14 at 21:26
  • Sounds good. If you do decide to make the change later, you can easily do it from Site Settings --> Look and Feel --> Master Page – Ransher Singh Nov 11 '14 at 21:48
  • For what it's worth. The "masterpage" option does not exist in Foundation. – Chris Nov 11 '14 at 21:49
  • Do you have a team site? Because the masterpage option requires the Publishing Infrastructure feature to be enabled. – Ransher Singh Nov 11 '14 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.