2

I asked a question about how to set up email notifications for access requests. It turns out that I do have that set up correctly. I am an owner of a site on SharePoint online.

However, I don't seem to be getting any emails from that notification. The email address that receives the notifications is working: I tested the email address by sending email to it from both internal and external email addresses and it's receiving email just fine.

Is there any way to "debug" whether the notification emails are sent? Some kind of log somewhere of the emails that are sent? Any other ideas why I might not be getting the emails?

  • Are you using Exchange Online? – Amal Hashim Nov 8 '14 at 2:36
  • Yes, I believe so. – Eilon Nov 8 '14 at 3:12
2
  1. Using Exchange Admin Center initiate a Message Trace. This will confirm whether the messages are being sent from SharePoint
  2. You can check the Quarantine and see it the email are there or not
  3. You can probably create a rule to bypass email from SharePoint (So no filter will get applied to those)

Read more here

  • Unfortunately I'm not an admin on Exchange. The only thing I'm admin on is this particular site in SharePoint. I'll contact our IT HelpDesk to see if they can help out with this. – Eilon Nov 8 '14 at 17:26
  • Do you know if there's any way to determine this from the SharePoint side of things? Some secret SharePoint admin page that might indicate successes/failures in sending status notifications? – Eilon Nov 10 '14 at 0:19
0

We've run into the same issue couple years ago, turns out the email address you add to the Access Requests settings must be an actual user that have access to the site. The way we handle it on our site is that we have a dummy user set up as site collection admin to make sure that user has permissions to the site and then in exchange we have a mail rule set up to forward any access requests emails this user is receiving to go to our DL.

0

We had the exact same Issue (On-premise), all E-Mail notifications were send out except Access Requests.

After a lot of debugging and log analysing, we found the Issue on the Exchange side. The Webapp Pool User needed Extended Rights on the Exchange Connectors.

The Rights that we needed to add:

  • Get-ReceiveConnector "<spconector>" | Add-ADPermission -User "DOMAIN\AppPoolAccount" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Sender"
  • Get-ReceiveConnector "<spconector>" | Add-ADPermission -User "DOMAIN\AppPoolAccount" -ExtendedRights "ms-Exch-SMTP-Accept-Authoritative-Domain-Sender"
  • Get-ReceiveConnector "<spconector>" | Add-ADPermission -User "DOMAIN\AppPoolAccount" -ExtendedRights "ms-Exch-SMTP-Submit"
-2

Make sure you either have Members Can Share turned on OR have your approval admin email address properly set.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.