4

The user is added to the site but unable to see the term, but is able see the page by typing URL manually.

While searching I could not find much except this post that didn't tell me much. What work around are their for this issue?

I know if you give them contributor permissions they are able to see it. This is not ideal, because it means they see other things they aren't suppose to.

  • Try to give explicit permission to the page. Open page -> Ribbon (Page) -> Page Permissions – Amal Hashim Nov 7 '14 at 20:18
  • Wanna add that as an answer so I can mark it answered if it works? – Lincoln Hach Yellick Nov 8 '14 at 21:16
  • Has the Term Set where the Friendly URLs are defined marked as 'Available for tagging'? – Waldek Mastykarz - MVP Nov 10 '14 at 2:44
  • @Waldek Yes the term in question has been marked as Available for tagging. Should it be unchecked? – Lincoln Hach Yellick Nov 10 '14 at 15:08
1

When working with Managed Navigation, menu items linked to pages with specific permissions set are automatically hidden from users without those permissions.

When using the Managed Navigation and modeling the site navigation with Terms, as long as the particular Navigation Term is linked to a page using the Term-Drive Page with Friendly URL option, the term will be displayed to users only if they have the necessary permissions to access the associated page.

Source

Hence make sure the user in question has correct permissions to the page. Or provide direct permission using

Open page -> Ribbon (Page) -> Page Permissions -> And add the user directly

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. – Waqas Sarwar MVP Nov 8 '14 at 23:15
  • @WaqasSarwarMCSE I posted it as an answer based on op's request. – Amal Hashim Nov 8 '14 at 23:58
  • mybad, i didnot see that. – Waqas Sarwar MVP Nov 9 '14 at 2:28
  • Sorry for the confusion. Any workaround if it works will be a good answer for me or someone with the same problem. Just making it easier for other people in the future looking for this problem – Lincoln Hach Yellick Nov 10 '14 at 0:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.