0

After i published app (not sure if related) to app o365 catalog (not store) i cannot debug app installed (or uninstalling) receivers using azure service bus anymore. I even tried removing remote endpoints from app manifest, but it did not help.

I also needed to increment app version in manifest to be able to event attempt debugging as app with same version was already in app catalog.

This is what is in output window

Successfully installed app for SharePoint.
Services/AppEventReceiver.svc has been registered on Windows Azure Service Bus successfully.
Services/AppEventReceiver.svc has been registered on Windows Azure Service Bus successfully.

When i click on start, app is uninstalled (if it is previously installed), then installed, then VS gets out of debug mode, then there are messages that service bus has been successfully registered. Then internet explorer starts and VS goes back to debug mode (probably for debugging javascript in IE), but this is after app installed receiver finishes (successfully btw).

Enable debugging via Windows Azure Service Bus is checked in project settings. Connection string to Azure Service Bus is provided. I created Service using powershell so it does support necessary authentication methods. Related web project is also set up in app project properties. Debugging using service bus worked for me on this project before.

Any ideas?

  • I stopped my public site (endpoint) and debugging still does not work while the receiver obviously works and upload files to server as supposed. – Evlo Jan 20 '15 at 13:40
  • I guess it is most likely general c# web aplication/server thingy issue, because it seams like app is running and no symbols are loaded. – Evlo Jan 20 '15 at 13:49
0

Ensure your web and sharepoint projects are both set as startup projects for a solution. Hope this helps.

  • 1
    That is nonsense, you can have only one startup project, which should be app, webserver then starts automatically. – Evlo Jan 20 '15 at 13:36
0

It works attaching iisexpress manually and then starting an app project.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.