0

Just wondering if anyone can point me in the right direction.

I've got a basic carousel script that works perfectly fine when I'm logged in to sharepoint but for some reason it just doesn't work for anyone else (ie anonymous users).

I've tried housing the script in the master page and in content editor on the page itself but no change.

Any ideas?

Thanks.

0

You need to check if the JavaScript files are checked-in and published, anonymous users can't see checked-out or unpublished files. Also make sure the library has anonymous access where the files are kept.

  • That's a good point and I'll double check that but as far as I know the files are published. Would it not have solved the issue then when I had the script embedded in the master page or even with the Script Editor web part? – Mike_Piercy Nov 6 '14 at 9:10
  • True it should have solved the problem then. Did you check that the browser has JavaScript enabled, did you try switching between different browsers? – Arsalan Adam Khatri Nov 6 '14 at 9:42
0

After checking console in browser I realised the issue was coming from a javascript error. A defined jquery function was not being recognised.

For anyone interested, this was due to two different jquery versions being included at different stages in the one document.

For some reason though, Sharepoint didn't see this as a problem for logged-in users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.