4

I was deploying my app and after 20 minutes I canceled the deploy by hitting AltGr + PauseBreak or Crtl + PauseBreak (don't remeber).

Now in SharePoint it just says We're removing your app... for about 1 hour. Has someone had this problem or know how to solve it?

enter image description here

4
  • Not much of a solution, but I've had this issue before. I'd change the app's guid, and continue working. The next day it'd usually be removed, and I'd revert the guid back to what it was.
    – wjervis
    Nov 5, 2014 at 15:08
  • 2
    ithink in this case, wait is better method or 2nd thing open a service ticket with 365 support team
    – Waqas Sarwar MVP
    Nov 5, 2014 at 15:31
  • It's gone took about 2 hours Nov 5, 2014 at 15:59
  • I have an impression that removing a CUSTOM app may take up to 24hours, but I cannot find any confirmation in the articles. It may be related to updates: msdn.microsoft.com/en-us/library/office/…
    – grisha
    Dec 2, 2014 at 15:27

2 Answers 2

1

Same here. SP Online is very very unstable. If something like this happens, you have to recreate your site collection or you have to change the name and GUID of your app and install it again. But if you have content in app parts for example, you will lose it.

1
  • i have same issue its been 5 hours now ..... nothing working
    – meer
    Feb 3, 2016 at 13:18
1

I've just faced the same issue and steps below fixed it for me:

SharePoint stuck removing the app because it can't find app package because deployment was cancelled.

Upload app package to App Packages and try to remove app again.

2
  • Much appreciate it ! It worked , i was waiting for 40 minutes until i tried out your solution
    – shak
    Oct 20, 2017 at 12:07
  • this works if its a custom app, but what if the app was from SharePoint Store? Like Adobe sign app is stuck on removing and cant figure how to remove it.
    – eSS92
    Jun 23, 2022 at 7:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.