0

I created a document library in Sharepoint Designer 2013. I want to edit the library settings and I will add new users for permission the document library. Then I go to library settings. And i clicked "Permission for this document library" and I added new user to groups. But the user don't see this document library items. Users got this error "Sorry, this site hasn't been shared with you". What else should I do ?

3
  • From what you described, you gave the correct permissions to users on document library only, not underlying site. Can you confirm that users are trying to browse URL in format servername/sites/test/Lists/listname/AllItems.aspx? Nov 5, 2014 at 13:55
  • @SlavenSemper I gave the permission to users on document library only. I didn't give permission for webpage. And users can't see [servername/sites/test/Lists/listname/Forms/AllItems.aspx]
    – zengel
    Nov 5, 2014 at 14:37
  • Make sure they also have access to the Style Library and the master page is published and approved. Nov 6, 2014 at 7:28

2 Answers 2

0

You should go to Site Settings and click on site permission's and provide proper permission to the site (Visitor/Member/Owner)

1
  • I gave full control authority already for this group.@AmalHashim
    – zengel
    Nov 5, 2014 at 13:49
0

This might sound stupid of me, but did you check the document library's permissions and associated the correct group to it ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.