2

We have one site collection where new sites are not inheriting the custom master page. The site collection is set to use it, publishing features are turned on, and I can even apply the custom master page after I create the site by checking the "Reset all subsites to inherit this site master page setting". It was working before so I am not sure what changed. I even copied the custom master page down from another site collection to verify there wasn't something wrong with the custom master page itself and it still the same thing. It just defaults to the v4.master page. No of the other site collections on the farm have this problem.

Any help is appreciated.

  • Make sure that publishing feature is enabled on the new site. – Amal Hashim Nov 4 '14 at 22:44
  • So I tested this and the feature is not turned on after creating a new site. When I turn it on it does apply the custom master page correctly. That said, I would think this would be inherited from the site collection. If not, then every time a new site is created the users would have to turn the feature on to apply the master page. I am pretty sure they have not had to do that in the past, let alone even know how to do it. I think I am going to toggle the site collection feature and see if that works. Thanks. – steveareeno Nov 5 '14 at 15:08
0

Publishing feature needs to enabled then only the master page will get inherited.

You can document this so users follows the correct procedure.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.