0

enter image description hereenter image description hereCreated a simple list workflow in SPD 2013 with ‘Start task process’ action. Didn't change any default values. Plan is to assign a task to multiple users to review a document, every time user adds one to document library. All works well. My list workflow sends an e-mail to user with the assign task.

My problem is, default task outcome ( Approved, Rejected) doesn't show up on the task form. It only shows the ‘close’ button along with other task information.

How do I get my default options to show up on the task form ?

  • Can you include a screenshot? – Slaven Semper Nov 4 '14 at 22:47
  • I'm sorry but how to attach a document or screen shot on this? I see an option for a link but not for an attachment – Hycinth Nov 4 '14 at 23:30
  • Edit your original post. In the editor ribbon you'll see a button to insert image. – Slaven Semper Nov 4 '14 at 23:35
  • Post a print from the Edit screen please – Choggo Nov 5 '14 at 1:56
0

You need to press Edit Item button to see buttons you want to see - Approve, etc..

  • Thanks Robert.I got it now. Is there a way I can give a link to the Edit form from the e-mail itself (user e-mail generated from workflow)? Default e-mail link goes to the form I displayed here. ( with the 'Close' button). I need user to see the 'Edit item' form so they can Approved/Reject the item. – Hycinth Nov 5 '14 at 22:49
  • My colleague was looking into that possibility but he couldn't find the solution. Please mark the answer as correct if it solves your original issue. – Slaven Semper Nov 5 '14 at 23:01
  • @Hycinth and Slaven - what was your approach to getting the ID of the created task in order to send it with the URL to the edit item form? – Kristopher Sep 22 '16 at 20:53
  • @SlavenSemper Hi Slaven, did you or your colleague ever find a solution to this? – Bassie Oct 6 '16 at 10:49
  • @Bassie Actually we did, unfortunately there is no room here in comments to describe it. I can post it as an answer if you're stil interested. – Slaven Semper Jan 26 '17 at 13:26
0

This happens, somehow, when you edit and add some code in the page or add code in content editor webpart, in any edit form of Task lists... If you have your edit form full default, it will show task outcome options as buttons again. It happens me when I tryed to hide the Content Type field from edit form, but I have the same issue that you.

Hope this helps you in some way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.