1

I have been trying whole day to configure search, set up the search service application, did a full crawl, had lots of internal errors and after a long day, did an iisreset and finally it was working. Hurray.

Now, my problem is that I want to show managed metadata as search refiners, but none are showing.

I found this post Managed metadata columns as search refiners but cannot find a tutorial on how to do it.

Can anyone help me?

[Update] Did the steps described in the first answer, but now came across a new problem. I can see the "Managed Metadata Columns" in the Filter, changed it to my column but still they are not appearing in the Search Refinement Panel.

<Category    Title="TopicMM"   
 Description="Managed metadata of the documents"    
Type="Microsoft.Office.Server.Search.WebControls.TaxonomyFilterGenerator"    MetadataThreshold="3"   
NumberOfFiltersToDisplay="3"    
MaxNumberOfFilters="20"    
ShowMoreLink="True"    
MappedProperty="ows_MetadataFacetInfo"    
MoreLinkText="show more"    
LessLinkText="show fewer" />  

[Update2] Silly of me. I forgot to uncheck the Default Configuration checkbox. Hope this helps others though.

0

Here are the steps you have to perform inorder to work.

  • Run Full Search Crawl.
  • On Search Admin page > under Queries and Results click Metadata Properties.
  • On the Metadata Property Mappings page click New Managed Property
  • Fill in the Property Name: NameofProperty
  • Under the Mappings to crawled properties click the button Add Mapping
  • In the dialog box, under Crawled property name type NameofProperty. Click Find. Select the crawled property ows_NameOfProperty(Text) and click OK.
  • Save the Metadata Property
  • Now that you have set up the Metadata Property, you need to perform a full crawl again. Follow the steps from earlier to do this.
  • Once the full crawl had completed, the way to check if it will work in a search it to navigate to your search center.

Complete steps on this link: Search Refiners with Managed Metadata

  • This did work partially. I can see the "Managed Metadata Columns" in the Filter xml, but they are still not appearing in the refinement panel. – user1109363 Nov 4 '14 at 3:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.