3

So I've created a custom form template based on the default ListForm (haven't changed much there, basically just the title), I've set up a custom content type and I've added that to a Tasks list. When I try to create a new task, I see this:

enter image description here

Does anyone knows why the ribbon could be disabled in this case?

  • My Guess is that what you changed somehow corrupted the page. Have you tried undoing your change? Do the buttons come back? – David Palfery Apr 30 '11 at 14:54
4

I had a similar problem to above - the ribbon options were grey (gray) when I showed a list item using a Rendering Template. The ribbon also showed a lot more options than you usually see when viewing an item.

My soltuion was simple though: I'd forgotton to include this line in the template:

<SharePoint:FormToolBar runat="server"/>

Once in the correct, active ribbon appeared.

Hope this saves someone some time ...

1

What do you mean "haven't changed much there, basically just the title"?

I tried to reproduce your issue, but my form for Tasks list doesn't look like yours:

my form

Here what I have done:

  1. Created new "Team Site" site collection
  2. Opened Tasks list
  3. Opened SharePoint Designer, created new form for the list, and marked it as the default MyNewForm.aspx
  4. Saved all the changes

So, you should probably recreate your form template, or provide more information about your issue (especially about list and form customizations).

1

Solved now. I was overwriting the default window.onload handler function for the iframe and thus preventing the ribbon from being initialized. I've switched to using jQuery to attach to the load event, and all works now.

  • Mihai hi can You describe your actions in more detail? – user4142 Jul 18 '11 at 10:55
  • 1
    Just comment out all of your custom Javascript from that page/rendering template, and see if the problem goes away. Then add it back bit by bit, and be sure to attach event handlers to controls using jQuery or a similar library. The ribbon buttons are greyed out by default, and are enabled by a custom Sharepoint JS function executing on page load, so you must take care that your own Javascript doesn't throw any exceptions/doesn't overwrite the default onload handler for the pop-up edit window. – Mihai Jul 18 '11 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.