7

I have configured the environment for SharePoint recently, and created a developer site in a web application, the user that's logged in to the machine has dbowner and dbsecurity on SQL, and has dbowner on the database for the web app, when I deploy my App, I go to the home page of my developer site, and click on the App, I get the popup asking for credentials, when I give it the username and password for the admin, it keeps giving the same popup, any idea?

How would I handle this for other users as well? I guess I am missing something regarding permissions on the App itself or the service application, any idea would help so much, thanks.

10

I'm going to assume here it's a SharePoint hosted app, so authentication is all centered around SharePoint. Provider hosted app may have additional authentication requirements and you would need to refer to vendors documentation on use.

SharePoint hosted app - is a sub-site of the site where it is deployed. By default this will inherit the permissions set on the site (though developer can deploy artifacts and break that inheritance internally). Now - when you access the app you will get the prompt for authentication because your browser will detect it is in a separate domain (at least it should be). This is by design to isolate the app from SharePoint so it can't access anything that it was not granted rights to access.

So for most browsers there is a method to automatically forward your credentials on trusted sites. For IE - you usually add the sites to the "Intranet Zone" which already has security configured for this. You need to add not only SharePoint URL, but your App domain in there as well. That should limit log on prompts for your internal users.

Now - if the credentials are rejected, you will see multiple authentication prompts. With SharePoint this means we are not even getting into site permissions yet (or you would see the "this site is not shared with you message"). Now it can get a bit tricky, as there could be multiple reasons this is happening.

First make sure your "admin" account has actually got access to the site hosting your app (if it's not the account you are logged in as).

Next take a look at what the app does - is it accessing something that you don't have access too? You can sometimes get this from the logs on the server hosting SharePoint. Another method is to load up Fiddler on your machine and generate the same result. Fiddler will show you what you are requesting access too and getting denied.

I'm assuming here Apps are also configured correctly, but just in case check these as well: Check the fiddler traffic to be sure your app access URL is what you expect (validate DNS is configured correctly) and not pointing you somewhere you didn't expect.

Make sure the site you direct your App DNS entry too does not have a host header assigned in IIS. If it does - extend your web app so you have a new IIS site with no host header and send your app redirect there.

Although you didn't state it - if there are any network devices like application firewalls, proxies, etc these could also be the source of your pain.

Even less likely due to the repeatable nature is your server losing contact with a domain controller, either from it being too busy or network packet loss. That could also result in popups since the web server would fail to validate a user.

  • Thanks Jesus, It's a SharePoint hosted App, installed on a site collection where am the site collection admin, I have dbowner permissions on the database, I am the one who created the web app, and the App is just the App that's given to you when you create new App from Visual Studio, nothing more added to it, but am still getting this authentication pop up, and it doesn't recognize my credentials. I have not checked the fiddler response yet, but any thoughts? – SharePoint Freak Nov 2 '14 at 17:01
  • My issue is not exactly the same. For me, the prompt is only for the first time and able to get into the application successfully upon entering credentials. Once I am in addin, no more credentials popup. If I close the browser and open addin again its asking credentials again. When I browse normal SharePoint site I am not being asked for credentials popup. – Ravi Khambhati Oct 25 '17 at 14:58
5
  1. Click on Start -> Run and type regedit.

  2. Locate the key 3. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

  3. Right click on this key and choose New > DWord Value

  4. Name this one "DisableLoopbackCheck"

  5. Double-click then on it and type the value “1”

  6. Reboot your server. (Mostly not required)

This helped me in resolving the issue. I am using windows server 2012 and on creating new dword it prompts 32 or 64 bit. I created 64 bit but it does not resolve the issue. I deleted that and created 32 bit dword DisableLoopbackCheck and setting its value 1 resolved my problem.

  • For me, this option is already there. My issue is not exactly the same as you are facing. For me, the prompt is only for the first time and able to get into the application successfully upon entering credentials. Once I am in addin, no more credentials popup. If I close the browser and open addin again its asking credentials again. When I browse normal SharePoint site I am not being asked for credentials popup. – Ravi Khambhati Oct 25 '17 at 14:57
1

I had to change option "Internet Options\Security\Internet\Custom Level\User Authentication\Logon" to "Automatic logon with current user name and password" as well to overcome this issue

-1

(Working Solution)See this link - https://sureshpydi.blogspot.in/2013/04/sharepoint-2013-issue-app-prompting-for.html?showComment=1470215481580#c6116519647350364803

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.