2

I have created 3 application pages for a List, NewForm, EditForm and DispForm to replace the out of the box forms. I have activated these pages as a feature and updated the NewFormUrl, EditFormUrl and DisplayFormUrl via tha list.ContentTypes["Item"]. This works great, however, when I Edit an item at the bottom of the list (i.e. the Ribbon is no longer in view and I just see list items) I have to scroll to the top of the page to see the application page.

I notice that the out of the box forms open at the top of the page too, but the user is scrolled to the top automatically. How to I get my new custom Application pages to scroll to the top of the page when opened. Is there a CSS setting I need to override? I have tried to find an answer to this but can't so hopefully someone has hit this issue before.

Thanks! enter image description here

  • Are you describing forms which are opened in a modal dialog in SP 2010? – Slaven Semper Oct 31 '14 at 16:17
  • Yes. They open as Modal Dialog like the OOTB forms. I have created the Application Pages using the SharePoint 2010 template via Visual Studio 2010. – Dave Stuart Oct 31 '14 at 16:20
  • Can you include a screenshot? – Slaven Semper Nov 1 '14 at 3:55
  • Hi Slaven, I have added a screenshot showing the Edit Page that is at the top of the page, yet I am not, If you look just to the left of the Save button in the disabled screen to can see the user I clicked. Ideally I want the Application Page dialog to open right were the item is that I'm editing, however moving to the top of the page will work too and that is how the OOTB forms work. – Dave Stuart Nov 2 '14 at 4:02
  • Sorry, I just check another site that has zero Master page customizations and that one works fine, so the problem is with the Branding. I will have to take a closer look at that as I didn't do that part! – Dave Stuart Nov 2 '14 at 13:47
0

It was the custom branding done by someone else that caused this issue.

  • Please use the edit link on your question to add additional information. The Post Answer button should be used only for complete answers to the question. – Waqas Sarwar MVP Nov 2 '14 at 21:28
  • @WaqasSarwarMCSE, this is an answer is it not? – Robert Lindgren Nov 3 '14 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.