The BDC content source I made was crawling "extra"/"garbage"/"unnecessary" data. The external database view only shows 6 items but the search results show 7 items. Crawl log for the content source also shows 7 crawled items. What could be causing this and what can I check to keep this CS from crawling that URL. I also tried recreating the BDC model and content source but still no luck. I know you can remove the URL from being indexed on the next crawl but that option seems to be not working. The URL is still being crawled even if that option from removing it from the next crawl has been selected.

  • Can you provide an example of the "right" and "wrong" data? It has to be something in the ECT. Nov 2, 2014 at 13:07

1 Answer 1


For unnecessary lists and items, there is an option under settings: List settings -> Advanced settings -> Allow items from this list to appear in search results : NO .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.