3

I'm seeing an issue where the PeoplePicker is not working in IE11. Works fine in other browsers as well as older versions of IE. Normally, when an exact match is not found, we see the red squiqqly line and you can click to select from the matches. In IE11, we're seeing some strange HTML and we are unable to click to select a match.

Picture of error with email address removed

This is what we should see: enter image description here

I was hoping someone might be able to point us in the right direction to resolve.

  • 1
    did you try to enable the Enterprise mode / compatibility mode for IE? what SharePoint version you are using? – Waqas Sarwar MVP Oct 29 '14 at 21:28
  • I assume you're picking people from a SharePoint group or list column? The reason I ask is because SharePoint stores any person values as a hyperlink, which is what you're seeing in the top screenshot. And for the record, IE11 sucks. AND it will cause other issues with SharePoint as well. – Omegacron Oct 29 '14 at 21:46
  • Adding the site to compatibility mode did "fix" the issue. We'll continue to look for a fix that doesn't require our users to change the compatibility settings themselves. – sween_sp Oct 30 '14 at 18:58
2

add your url to your intranet zone on IE. I have not yet dug down to see which security setting affects the rendering.

2

I second the answer from Jesus Shelby, although the problem is not caused by the security settings.

The question is probably for SharePoint 2007, which produces crappy code. In order for the crappy code to render correctly, IE has to use the compatibility view to render the page. You can enable this by clicking [F12] and choosing Document Mode = IE 5 (Default) in the developer tools. What this means is that you browser now acts like it was built 20 years ago, in order to be able to properly read the generated SharePoint code which is crap (like it was build 20 years ago).

To make this change permanent, you just need to:

  1. go to Internet Options > Security
  2. Click 'Local Internet'
  3. Click 'Sites'
  4. Select 'Automatically detect intranet network'

In most organisations, this is set by a group policy for all users.

I just hate Internet Exploder....

  • Unfortunately, this was already checked and it didn't prevent the issue for us. Most likely because it is a public facing site. – sween_sp Oct 30 '14 at 18:55
1

Add site to Compatibility view. Open SharePoint site in IE > press Alt to get the menu > Tools > Compatibility View settings > Type: Your Organization site URL > Add > Closeenter image description here >

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.