0

I recently got my hands on a SharePoint 2007 single server farm. The exact version number is 12.0.0.6545. This farm has been running for many years.

The Convert License Type page says Office SharePoint Server Trial with Enterprise Client Access License

Is the license actually expired? I am able to do all sorts of things on this farm but there are some functions which when I perform give error The trial period for this product has expired so I am not really sure if it is expired or not.

For e.g. if I try to create a new site or site collection with template "Publishing Site" then I get this error. All other templates work fine for e.g. Team Site, Document Workspace etc.
Similarly if I try to add a workflow to a list or library then I get this error.

My farm account is part of local admin group and all application pools are running using this account. Similarly, SharePoint timer job is running with this account. I have done iisreset several times but no luck.

The only thing remaining to do is to run SharePoint Configuration Wizard but I dread to run it lest it breaks something.

How do I fix this issue? Is SharePoint Configuration Wizard the only solution?

3
  • 1
    "How do I fix this issue?" Buying a license seems like a good start.
    – Geeky Guy
    Oct 28, 2014 at 12:50
  • Could be a bug as I found this but I will confirm it from customer tomorrow. support.microsoft.com/kb/971620. By the way if the license has really expired then shouldn't SharePoint cease to work? Or this is normal behavior that after license expiring, some functions work and some don't? Oct 28, 2014 at 12:57
  • I don't know about SharePoint specifically, but this is typical Microsoft - if you install some versions of Windows and don't activate, or if it is a pirate copy, you will be able to use it, but lose some functions. For example, the wallpaper will always be black, you don't get non-security updates etc.
    – Geeky Guy
    Oct 28, 2014 at 13:39

1 Answer 1

0

Turns out the license was actually expired. After expiration of license MOSS was working in Foundation mode. I applied license and now all features are working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.