1

I downloaded a hand-made equivalent to the SharePoint Server 2013 Publishing Feature here SharePoint Foundation 2013 Publishing Infrastructure. i'm on a single farm, running a SP Foundation 2013 with the last cumulative update.

I watched the Deployment.ps1 code, it's ok and use SharePoint Powershell methods. I ran it, and everything went well. Then I've reached my root site, and in the site settings > manage site features I saw the new SP solution deployed and installed, ready to be activated.

When I click on "Activate", it return a message like "an error has occurred" and without any useful information. even any informations at all.

If you already managed to install this solution can you please tell me what can it be ? My SharePoint version ? A bad installation ? Thanks a lot !

EDIT : I found on the logs 2 lines that should be the error :

Exception: System.ArgumentOutOfRangeException: [...] Parameter name : Type of content not found (ID : « 0x010100F2A9C1C92EF041A086F2FEEAA284FF80 »).

at Microsoft.SharePoint.Administration.SPElementDefinitionCollection.ProvisionContentTypeAndEventReceiverBindings(SPFeaturePropertyCollection props, SPSite site, SPWeb web, Boolean fForce)

These lines comes just after trying to activate the feature :

Feature Activation: Threw an exception, attempting to roll back. Feature 'SharePoint.Foundation.Publishing.Infrastructure.Web' (ID: 'e0f1805a-6501-42ad-9c56-60d4c8339c58').

  • SharePoint logs the error details to the ULS. It's linked to the Correlation ID of the "an error has occurred" screen. Can you post that information? – Choggo Oct 24 '14 at 14:48
  • I checked my log (which are on verbose mode) and I got 66 lines concerning the issue. I can add that I have the good rights in order to manage the features of the site. I posted the logs here : dropbox.com/s/xu9khvggpyzvn7x/piece_of_log.txt?dl=0 PS : download the txt file for more visibility (line by line). Thank you very much ! – Alex Oct 30 '14 at 8:07
0

I succeeded to enable the feature on my site collection. I made it by finding the ID of the deployed and installed solution. then, with PS and the SharePoint Snapin I just wrote :

Enable-SPFeature -identity <longggg-id> -url https://mysharepoint/sites/company

And simply by magic, the feature was unlocked-like. I can now disable/enable it from the Feature management page (GUI) in SharePoint preferences, without any errors. WEIRD is the word I would suggest, and I let some hairs behind with over-complicated analysis.

0

It's been some time, but sharing this to save someone from hassle. As you mentioned, I looked for the feature and found two similar one, one was ending with Site and other one with Web. I had to enable Site first and then Web and it worked :)

PS C:\Users\sharepoint.admin> enable-spfeature -identity 92b89c55-e493-4a07-9051-e09b61985a46 -url http://Server/sites/testsite
PS C:\Users\sharepoint.admin> enable-spfeature -identity e0f1805a-6501-42ad-9c56-60d4c8339c58 -url http://Server/sites/testsite

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.