I have an issue on one of my sharepoint enviriontments regarding some kind of javascript problem with the Content Editor Web Part which keeps returning me these errors when I try to user the RTF-text editor:


Message: Invalid argument.
Line: 5739
Char: 2
Code: 0
URI: http://URL/_layouts/1033/HtmlEditor.js


Message: 'null' is null or not an object
Line: 2325
Char: 2
Code: 0
URI: http://URL/_layouts/1033/form.js?rev=df60y6YolDjUVbi91%2BZw%2Fg%3D%3D

I have tried to follow the following solution guides from bloggers etc:

But none of them seemed to help me. They made my troubleshooting a lot easier and helped me figure what I should google some more towards, but I have not yet found a solution.

Have any of you experienced the same problem, and how did you solve it?

Edit (request from @omlin)

The errors occurs on all sites on the website. Every page is using pure standard pagelayouts, no custom masterpage is used. I have some custom webparts on the pages, but that has no influence as the error occurs on blank pages too. I tried changing the language packages from English to Danish and vice versa, but no effect. So I'm clueless whatsoever about this.

  • Please, provide additional information: do you get this errors on all possible pages, even on completely blank, or only on pages with your customizations/webparts? Do you have masterpage customizations? Did you try to create new blank site collection and add CEWP on blank page there? Apr 27, 2011 at 14:39
  • What browser(s) have you tested? Tried clearing the cache? Tried different client machines?
    – Alex Angas
    May 16, 2011 at 23:30
  • What exactly is the line of js that is throwing an error? could you post it here? I only have SP2010 running at the moment...
    – Colin
    Jun 24, 2011 at 17:58

1 Answer 1


Since your problem is isolated to one environment, no additional JavaScript files are included, and the issue arises on even blank pages, I would recommend the following:

  • Ensure none of the SharePoint JavaScript files have been modified directly (shudder):
    • a) Check none of the modification dates are much later than expected
    • b) Use a comparison tool to find any differences between that environment's JavaScript files and an unmodified installation
  • Check no other JavaScript files have been included by other means:
    • Track the loaded files in the Network tab of Chrome's developer tools (or similar), and compare to an identical page on an unmodified server.

Unfortunately these are hand-wavey suggestions, rather than specifically targeted at your issue. It seems the more specific resolutions have been unsuccessful, so starting again from a more general standpoint (as in the above) may help you track it down.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.