1

When I modify my CSS file (Correctly referenced on my Master Page) nothing happens.

I checked out the file, modified it, checked it in and published it in a major version but still nothing. Clearing the browser cache either.

However when I create a new CSS file and change the reference in the Master Page, this works well.

The same thing is happening with images.

2
  • Try clearing browser cache. Oct 24, 2014 at 10:24
  • Post edited. Clearing the cache dosn't solve the problem.
    – Mehdi
    Oct 27, 2014 at 13:09

1 Answer 1

0

Check the inheritance of the master page. Check it at top and sub site level. If it's inheriting to sub sites, you can reset it for these sites to push your changes down.

Go to the top level of your site collection then Site Actions > Site Settings.

Under Look and Feel, select Master Page and confirm that the master page you're making changes to is set as the Site/System Master Page. Check the box to reset all sub sites to inherit the master page and then OK.

6
  • I checked the inheritance settings and all sub sites are actually inheriting the master page where i made changes. As i mentionned, when I create a new CSS and refenrence it on my master page it works but not when editing existing one ! The problem occurs also with images : When I overwrite an existing image, the master page still uses the old one !
    – Mehdi
    Oct 24, 2014 at 12:26
  • Have you tried restarting IIS?
    – Stuart C
    Oct 24, 2014 at 12:50
  • No, If i should do it each time I modify my css it will be a desaster ! I'm actually developing ...
    – Mehdi
    Oct 24, 2014 at 13:09
  • 2
    did you try clearing blob cache using powershell? Oct 26, 2014 at 16:58
  • 1
    @SharePointer The problem was caused by the BLOB cache. It keeps a copy of the old CSS and doesn't consider my edits in the new ones.I removed the CSS Files from the BLOB Configuration (To avoid cleaning it each time I modify the CSS Files). Could you please post your answer so I accept it ?
    – Mehdi
    Dec 1, 2014 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.