0

I enabled the SharePoint Server Publishing feature and now it change my navigation bar, putting the selected site in the first order, but I don't want my navigation bar changes the order of the links. I can't edit the order because it does not appear when i click in the EDIT LINKS.

How can I fix that?

enter image description here

1

A solution would be :

  1. add a script editor web part to your page
  2. copy the following code into the script editor

SharePoint 2013 code

.ms-core-listMenu-horizontalBox li.static > a{ 
     display: none !important;
    }
 .ms-core-listMenu-horizontalBox li.static > ul a{ 
    display: block !important;
    }

SharePoint 2010 code

    .s4-tn li.static > a{ 
 display: none !important; 
 } 
 .s4-tn li.static > ul a{ 
 display: block !important; 
 } 
  1. In Site Settings -- Navigation create a new link to the site enter image description here

Hope this helps!

0

You can go to site setting and navigation setting. In this page you have the option to rearrange links are per your requirements.

  • The link of the site where i am, it does not appear neither in the navigation setting. It just say "current navigation" in the navigation setting but i cant move it. please be more specific. – mejiamanuel57 Oct 22 '14 at 14:03
  • Are you one the top level? Do you have enough permission to edit the links? – Amal Hashim Oct 22 '14 at 14:08
  • yes. i'm the site administrator. – mejiamanuel57 Oct 22 '14 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.