1

I have a library with document sets. Normally in the ribbon under "New document" I can only create new document sets when I'm in the top most level.

Only when I am inside a document set this ribbon action allows to create/upload documents.

Somehow I managed that I now also have the option to create documents, even on the top level of the library - where Microsoft says this should not work (well I cannot upload a document to that location but the ribbon action is still there).

Does anybody know how to get rid of those invalid ribbon actions?

0

Apparently the issue seems to have been solved. I'm not 100% sure what solved it though.

I think in the Library Settings I edited the content type settings "Change new button order and default content type" and deselected the documents completly (they are still available inside an document set).

I think the change is not direclty visible as after changing the setting the ribbon still lets you create the documents but after some time those options will go away. Maybe (like a lot of other document set things) a timer job in the background is applying the changes only from time to time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.