This question already has an answer here:

As title, I've done every single step to sync user's picture, but it's still doesn't work. I don't know what to do now to make it work. Any idea?

  1. I've selected "Use SharePoint Active Directory Import" in "Configure Synchronization Setting". enter image description here
  2. In "Manage User Properties" I've set up the mapping with "thumbnailPhoto" attibute for Picture. I can see . "Picture---URL---thumbnailPhoto". enter image description here
  3. I've run full sync and get 241 users from AD enter image description here
  4. Then I open PowerShell Command and run "Update-SPProfilePhotoStore -CreateThumbnailsForImportedPhotos 1 -MySiteHostLocation mysitehostURL" . And there is no error. enter image description here Finally I checked it again but still didn't work.?

marked as duplicate by Robert Lindgren Oct 21 '14 at 5:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • You should update your original question, not post multiple almost identical ones – Robert Lindgren Oct 21 '14 at 5:24
  • This is not correct, in that question he explain the ADI rather fixing the profile picture issue.this should not be duplicate. – Waqas Sarwar MVP Oct 21 '14 at 11:19

This is not supported with Active Directory Import. We had the same issue where we want to import the Profile Pictures using ADI but after configuring everything nothing showed up.

We open the case with MSFT for this issue, almost in 2 months we reached to escalation Team and they confirmd this.

Profile Picture import is not supported in ADI becuase ADI import not supporting the complex properties so do PP is complex property.

I asked the same question on this forum almost same time i open the case. Importing the Profile Picture from AD using ADI & ADFS

  • tks u. In Configure Synchronization Setting I dont use AD Import anymore, instead I Use SHarepoint Profile Synchronization. And start User Profile Sync Service. Then Do the same other steps and it work now :) – user3622351 Oct 21 '14 at 6:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.