3

I'm trying to prevent users from changing their photo and personal information in mysites.

I go to SharePoint Central Admin > click Manage web applications > click the mysites web app > click User Permissions in ribbon > then Uncheck "Edit Personal User Information".

I click Save and go back to mysites and I can still edit this information. I even recycled the app pool mysites lives in, but no dice.

Is there another way to do this that works?

enter image description here

enter image description here

TL;DR? I was not able to edit user profile properties in IE11, switched to chrome and it worked.

2

2 things,

  • Choggo already mentioned in his response that if their are certain properties then edit that proptery and select Do not Allow...
  • 2nd method you just applied, You need to read this

"If Create Personal Site is checked, users may edit their profile regardless if the Follow People and Edit Profile is checked. So the only way you can turn this off is if you uncheck Create Personal Site as well as Follow People and Edit Profile."

http://stevemannspath.blogspot.com/2013/09/sharepoint-2013-preventing-users-from.html

enter image description here

  • I have both unchecked, and I can still edit my mysite personal information. I have given myself admin privileges to User Profile Service Application but I can not edit the user properties. Could be that I'm missing other privileges but not sure where. – Brandon Runyon Oct 20 '14 at 18:31
  • which property you are trying to edit...could you please give us the property name? – Waqas Sarwar MVP Oct 20 '14 at 19:12
  • I'd like to restrict all the properties if possible, but for starters I'd like to disable changing their photo. We really prefer that their mysites information that comes from AD remain as it is. I'll be happy to provide other information if you need it. I'm in the farm admin group so I'm supposed to have everything on the box. – Brandon Runyon Oct 20 '14 at 19:17
  • Becuase of Farm admin you are still able to profile information...did you try with a test user after changing th epermissions – Waqas Sarwar MVP Oct 20 '14 at 19:21
  • could you please share the screen print where dont allow users to edit....option is disabled....You can also set the Property as Import only... – Waqas Sarwar MVP Oct 20 '14 at 19:21
3

Which fields can be edited by a user is configured at the User Profile Service Application

Profile Service Application > Manage User Properties > Select the Property you want to block > Select the Option Disable Access

  • I can't select or change the properties. They are just listed out. Is there something I need to do to make them configurable? – Brandon Runyon Oct 20 '14 at 16:17
  • Depending on the User Property many of the options will be greyed out. The edit Settings should be enabled. If it's not, try adding yourself as an administrator for the User Profile Service Application. – Choggo Oct 20 '14 at 16:19
  • Okay, I've added myself as an administrator on User Profile Service Application using this reference: technet.microsoft.com/en-us/library/ee721057.aspx unfortunately it doesn't give me a way to edit the properties. – Brandon Runyon Oct 20 '14 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.