1

We have a Sharepoint 2013 installed with SQL database Cluster and our old Sharepoint 2010 databases should also be moved to the new SQL database Cluster but not migrated to Sharepoint 2013.

I have the problem that SP2013 is creating a "WSS_UsageApplication" database on the cluster. But on the old SQL server, Sharepoint 2010 also created a "WSS_UsageApplication" db. Those dbs have no GUID attached to their name and now i can not copy this db to the new SQL cluster.

Is there a way to move the SP2010 databases on the same SQL server where SP2013 databases are set up?

1

You need to rename one of the Databases. Is the Usage database the only one with a conflicting name?

You can try:

  1. Removing the service application without deleting the database
  2. Using SQL Management Studio to rename the database to a new, non-conflicting name
  3. Provision the service application pointing to the renamed database

Step by step: http://technet.microsoft.com/en-us/library/jj729804(v=office.15).aspx

To stop the Service Application, try:

$usage = Get-SPUsageApplication 
$usage.ServiceInstances | % {Stop-SPServiceInstance $_.ID}

And to start them back up, you can use:

$usage = Get-SPUsageApplication 
$usage.ServiceInstances | % {Start-SPServiceInstance $_.ID}
  • What do you exactly mean with removing the service application? – Florian Leitgeb Oct 20 '14 at 12:06
  • That database is used by the Usage and Health Service Application. The idea would be to reconfigure this service applicaiton, pointing it to a new database. I'm adding an msdn link to my answer to guide you through it. – Choggo Oct 20 '14 at 12:10
  • Just keep in mind to research the proper steps for the other conflicting databases, if you have them. Most of them should allow for similar steps to resolve the conflict. I think the only database you can't rename is the SharePoint Configuration database. – Choggo Oct 20 '14 at 12:20
  • Your explanation is very good, but i can not find the "Usage and Health Data Collection service" in the Manage Services on Server section. So i am stuck at the "stop service" step. – Florian Leitgeb Oct 20 '14 at 12:28
  • It should be listed in the "Manage Service Applications" link in your Central Administration. The name may vary but the Type should be "Usage and Health Data Collection Service Application" on your 2013 installation. – Choggo Oct 20 '14 at 12:38
1

Here is a guidance to rename the Usage and Health Data Collection service application: http://technet.microsoft.com/en-us/library/jj219726(v=office.15).aspx

  1. Stop your Service with:

    $usage = Get-SPUsageApplication 
    $usage.ServiceInstances | % {Stop-SPServiceInstance $_.ID}
    
  2. In your SQL Management Tool Rename the database. I had problems doing this because the timer service also had a connection. So i have set the db to offline, then set it to online and all connections were terminated. Not the most elegant way, but it was efficient.

  3. In your Sharepoint Administration Portal, browse to monitoring and then select Configure usage and health data collection.
  4. Uncheck Enable usage data collection and Enable health data collection. Click OK.
  5. Get back to the Configure usage and health data collection.
  6. Change the Database Name to the new one and check the 2 boxes you unchecked in step 4.
  7. Now the service should be running again. For safety use the following command in the Sharepoint Shell:

    $usage = Get-SPUsageApplication 
    $usage.ServiceInstances | % {Start-SPServiceInstance $_.ID}
    

And do not forget to rename your log file according to your database!

0

I recommend a separate SQL instance on the cluster if possible. Helps to keep them separated and manage them as if they're two separate SQL Servers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.