1

I created views based on a category field and then created calendar overlays based on those views.

The view I created were all calendar views as when I first created standard view it didn't show up when creating a calendar overlay.

The only problem I'm facing is when I click on a view I created showing up in the left quick launch menu where the default calendar isn't going to the view but just the default calendar and the default color

Hope this makes sense: it's not retaining the views and the colors selected when I did the overlays.

Edited here - Images here to see : This is the default view with color coding which works well http://i62.tinypic.com/5214s8.gif

Holiday View which I cant see a link to the view and the colors don't retain.But I have used Amals solution below in this post but that mean I have to do it for every view http://i57.tinypic.com/keddvl.gif

0

There is no out of the box way to set that. You best option is to edit the view page and add a snippet web part. Inside the snippet use below style

.ms-acal-item {
    background-color: red; /*Change red to the color you mentioned in the overlay*/
}
  • Hi Amal,thanks for the response but can you please elaborate more? Do i have to set this for each calendar overlay i created and where should i set this. – naijacoder Oct 22 '14 at 2:40
  • @naijacoder you need to click the calendar from left quick launch. This will take you to the calendar view where you are losing the color. Edit the page and do as I suggested – Amal Hashim Oct 22 '14 at 12:34
  • Thanks Amal will give that ago. But let me elaborate again My issues is when i click on the view or select a view its doesnt retain the link to the view on the quick launch despite that the link to the view in the browser is correct and the colors dont show up but the view shows the right items – naijacoder Oct 23 '14 at 1:34
  • Amal that worked like a charm but since the colors are different I would have to edit the page for all the views. Please see my original post I have edited it with some images.Thanks – naijacoder Oct 23 '14 at 6:29
  • @naijacoder there is no other option other than editing the page and adding the CSS. You can put the page in edit mode to do that. – Amal Hashim Oct 23 '14 at 8:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.